Visit the Ironworks Gaming Website Email the Webmaster Graphics Library Rules and Regulations Help Support Ironworks Forum with a Donation to Keep us Online - We rely totally on Donations from members Donation goal Meter

Ironworks Gaming Radio

Ironworks Gaming Forum

Go Back   Ironworks Gaming Forum > Ironworks Gaming Forums > Miscellaneous Games (RPG or not)

Reply
 
Thread Tools Search this Thread
Old 04-29-2005, 06:33 AM   #1
Wolfie
Zhentarim Guard
 

Join Date: February 1, 2002
Location: Australia
Posts: 307
I'm looking for about 5 or so people with the v1.2.4 Wiz8 CDs to test my "de-patch" utility. The idea behind this patch is that it downgrades (or de-patches) from v1.2.4 back to v1.0. If it works, with Wiz8 back to it's original v1.0 state, you can then patch to whichever point you personally want (would recommend going to at least v1.1b as that squashes two of the worst game-killers, the Mook hologram and Ascension Peak crash bugs).

If you're asking yourself, "Why on earth would anyone want to do that?", it's to do with the way pick-pocketing was changed in the v1.2.2 patch (and included in the later v1.2.4). While I myself have never had any interest in the Wiz8 pick-pocketing, and so wasn't fussed when the patch changed things, also accept there are people who do want to, but got the v1.2.4 CDs and so have been excluded from even trying.

It's not without risk, so would suggest only volunteering if you're comfortable using Windows Explorer, deleting directories etc, as it is possible the Wiz8 un-install will no longer work after this de-patch (it's one of the things I'd like to test). Also, any save-games made with Wiz8 v1.2.4 will NOT work with older versions.

Here's what I'm doing to make the de-patch: Install Wiz8 twice (in two different locations), apply the Wiz8Patch2001_12_23.zip (v1.2.4) patch to one installation. Then using patch making software, tell it the Wiz8 v1.2.4 installation is the "older" version, and the v1.0 is the "newer".

In theory a v1.0 Wiz8 patched to v1.2.4 is exactly the same as if installing directly off v1.2.4 CDs, however, since I don't have v1.2.4 CDs, can't personally test it, hence the request for volunteers.

Any brave souls willing to give this a go? Send me a PM or use the 'Feedback' form on my web site with your valid e-mail address, and I'll be sending you details in a day or so. Remember you need CDs with "v1.2.4" printed on them.

TIA
[img]graemlins/question.gif[/img]
__________________
Visit [url]\"http://www.foerster.cc/wolfie\" target=\"_blank\">http://www.foerster.cc/wolfie</a> or [url]\"http://wiz8.web1000.com\" target=\"_blank\">http://wiz8.web1000.com</a> (US) for a spreadsheet that allows you to enter in your spellcaster\'s stats, and it will tell you what spells the character can learn, or for spells that they are not yet able to learn, it will tell you how many points they need, or why your character can\'t learn the spell.
Wolfie is offline   Reply With Quote
Old 04-29-2005, 07:14 PM   #2
Scatter
Symbol of Cyric
 

Join Date: August 17, 2003
Location: Portland
Age: 58
Posts: 1,336
actually, the very first patch fixed AP. That was its sole purpose. And, if you don't start camping until the hologram fades completely, there's no trouble at the Embassy, either.
I've been using the first patch most of the time i play, since i first found out i needed any patch. (i got the original game when it was first delivered).
The only thing "bad" about the first patch is still bad on 001b; the Toxic Cloud spell can permanently poison a party member. The third patch is the one that wrecked Pickpocket, and the last one fixed the infinite Brekek.
Scatter is offline   Reply With Quote
Old 04-29-2005, 11:44 PM   #3
Wolfie
Zhentarim Guard
 

Join Date: February 1, 2002
Location: Australia
Posts: 307
Whatever, this utility would take v1.2.4 back to v1.0, what you do after that is your own decision. The whole point of this is for those who have the already-patched CDs who don't get a choice. This topic only applies to people with CDs that have "v1.2.4" printed on them, as per the topic title.

So far, only had two respondents, so doubting if there is much "demand" for this.

[img]graemlins/saywhat.gif[/img]
__________________
Visit [url]\"http://www.foerster.cc/wolfie\" target=\"_blank\">http://www.foerster.cc/wolfie</a> or [url]\"http://wiz8.web1000.com\" target=\"_blank\">http://wiz8.web1000.com</a> (US) for a spreadsheet that allows you to enter in your spellcaster\'s stats, and it will tell you what spells the character can learn, or for spells that they are not yet able to learn, it will tell you how many points they need, or why your character can\'t learn the spell.
Wolfie is offline   Reply With Quote
Old 05-15-2005, 10:42 PM   #4
Wolfie
Zhentarim Guard
 

Join Date: February 1, 2002
Location: Australia
Posts: 307
For those of you who might be following this, hit a rather big show-stopper of a problem, it seems there are US v1.2.4 CDs and EU v1.2.4 CDs (which was news to me), the EU v1.2.4 CDs installs a WIZ8.EXE which is only 103KB in size (whereas the WIZ8.EXE I've got, which was patched up from US v1.0 CDs is over 3.4MB in size, I'm awaiting a reply from one of my US testers on file size of their WIZ8.EXE, but so far the reports coming in are that the de-patch still fails.

Having two different v1.2.4 CDs releases (US English and EU English), neither which seem to be binary-exact as a v1.0 patched to v1.2.4 means a bit of a re-think is required. Since I don't have access to either of the already-patched v1.2.4 CDs personally, have no way of being able to use a patch-making utility to create the de-patch program. Besides, the 2 times I've considered doing this, had only lukewarm interest (guessing most here have the v1.0 originals), so for now I'm dropping the idea (at last I can recoup some disk space!).

My thanks goes to Gator621 / Jetlaw (VN Boards) and Silpion / GMK (IronWorks) for volunteering.

[img]graemlins/cookiemonster.gif[/img]
__________________
Visit [url]\"http://www.foerster.cc/wolfie\" target=\"_blank\">http://www.foerster.cc/wolfie</a> or [url]\"http://wiz8.web1000.com\" target=\"_blank\">http://wiz8.web1000.com</a> (US) for a spreadsheet that allows you to enter in your spellcaster\'s stats, and it will tell you what spells the character can learn, or for spells that they are not yet able to learn, it will tell you how many points they need, or why your character can\'t learn the spell.
Wolfie is offline   Reply With Quote
Old 05-22-2005, 09:18 PM   #5
vesselle
Hathor
 

Join Date: April 6, 2001
Location: the desert
Posts: 2,296
thanks for all the work, wolfie. i'm sorry it hasn't worked out. be nice to have something like that around, but i think you're right when you say most of us here got the game on release day, so still have the 1.0 cds.

maybe one day, when we've worn these ones out and can only find the 1.2.4 versions, there will be more demand for that.

*note to self* MUST remember to put all the patches on a cd. it's been getting hard to find a site that actually has each one.
__________________
my best friend is a junkie.
what does your best friend do?
vesselle is offline   Reply With Quote
Old 05-23-2005, 08:04 PM   #6
Wolfie
Zhentarim Guard
 

Join Date: February 1, 2002
Location: Australia
Posts: 307
Maybe one day I'll be able to get my hands on a set of both v1.2.4 CD variations, and then it would be fairly easy to do.

Quote:
MUST remember to put all the patches on a cd. it's been getting hard to find a site that actually has each one.
I've got 'em all (v1.1, v1.1b, v1.2.2 and v1.2.4) and my web site is not leaving in the foreseeable future.

[img]smile.gif[/img]
__________________
Visit [url]\"http://www.foerster.cc/wolfie\" target=\"_blank\">http://www.foerster.cc/wolfie</a> or [url]\"http://wiz8.web1000.com\" target=\"_blank\">http://wiz8.web1000.com</a> (US) for a spreadsheet that allows you to enter in your spellcaster\'s stats, and it will tell you what spells the character can learn, or for spells that they are not yet able to learn, it will tell you how many points they need, or why your character can\'t learn the spell.
Wolfie is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for Beta Testers lostzac Miscellaneous Games (RPG or not) 13 01-15-2005 12:17 AM
Mod testers wanted! Chewbacca Neverwinter Nights 1 & 2 Also SoU & HotU Forum 9 08-04-2002 03:19 AM
Play Testers The Old One Dungeon Craft - RPG Game Maker 0 06-06-2002 06:25 PM
all beta testers Aar-Daneel Neverwinter Nights 1 & 2 Also SoU & HotU Forum 18 05-14-2002 09:19 AM
Set your own starting XP (SoA and ToB)!- testers required... Vaskez Baldurs Gate II Archives 11 11-30-2001 09:15 PM


All times are GMT -4. The time now is 01:51 PM.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
©2017 Ironworks Gaming TM & The Great Escape Studios - All Rights Reserved