Visit the Ironworks Gaming Website Email the Webmaster Graphics Library Rules and Regulations Help Support Ironworks Forum with a Donation to Keep us Online - We rely totally on Donations from members Donation goal Meter

Ironworks Gaming Radio

Ironworks Gaming Forum

Go Back   Ironworks Gaming Forum > Ironworks Gaming Forums > Neverwinter Nights 1 & 2 Also SoU & HotU Forum

Reply
 
Thread Tools Search this Thread
Old 06-21-2003, 08:15 AM   #1
SpiritWarrior
Jack Burton
 

Join Date: May 31, 2002
Location: Ireland
Posts: 5,854
Well I'm hoping a mod will make this sticky since I know alot have yet to (or don't intend to) upgrade to SOU the expansion for NWN's. This way we can gripe about bugs or post questions on the latest patch here. They have made a huge amount of modifications and added a large amount of new stuff such as various scripting commands etc. all in the wake of SOU.
You can with this patch, accomodate SOU gamers into your regular NWN's server even if you do not have the expansion yourself.

Summary of fixes new to this patch:

Added compatibility for 1.30 SoU clients connecting
Added Hobgoblin and Pit Fiend creatures to the game resources.
Added 50+ scripting commands
Added scripting database access
Stability improvements
Improvements to network performance
Cheat/hack prevention


For an in-depth and complete list of fixes in this patch visit :

http://nwn.bioware.com/support/patchdetails.html

There you will see over a hundred modifications made to the game in 1.30


Just to throw my two cents in, I for one have noticed they seriously messed up resistances . It seems now that previously allowed stacks of resistances on armor etc. are now being tagged as level 21 and over. I imagine this is a new set of rules incorporated into SOU to avoid overpowering but in PVP this is BAD news, so many are complaining about it. I had to remake all my chars equipment as most of my items I couldn't even use anymore! *Groan*.

[ 06-21-2003, 08:27 AM: Message edited by: SpiritWarrior ]
__________________
Still I feel like a child when I look at the moon, maybe I grew up a little too soon...
SpiritWarrior is offline   Reply With Quote
Old 06-22-2003, 08:08 PM   #2
SpiritWarrior
Jack Burton
 

Join Date: May 31, 2002
Location: Ireland
Posts: 5,854
An FYI for all those non-SOU players/dm's. SOU spells can be seen by a non-SOU PC in a non SOU server. The animations and effects of these spells have been copied with the latest patch. The one thing I did not find to work was petrification. The animation for is not there nor is the effect itself and when such a spell is cast successfully on someone it really has no effect when used within a non-SOU server.

This is good news cuz for all of you who don't have SOU, you still get to see some new stuff but on the other side of the coin there are downfalls; you can't create items in the regular toolset that grant immunities or afford bonuses to these spells so in PVP you either don't duel those with SOU or upgrade. Hey, there's always general spell resistance. [img]smile.gif[/img]
__________________
Still I feel like a child when I look at the moon, maybe I grew up a little too soon...
SpiritWarrior is offline   Reply With Quote
Old 06-30-2003, 10:43 PM   #3
Tyranny]SiN[
The Magister
 

Join Date: August 29, 2002
Location: Faerun
Age: 36
Posts: 102
having a problem wif the update -

I tried to do a regular update and got the same error "Invalid Pointer Operation"

I then tried a Clean Install and then updated to 1.30 and to no avail got the same error.

I'm thinking maybe since i never had any known errors i could maybe NOT update [img]smile.gif[/img] . Just a thought. You need my system Specs?
Tyranny]SiN[ is offline   Reply With Quote
Old 06-30-2003, 11:07 PM   #4
TheCrimsomBlade
Lord Ao
 

Join Date: August 25, 2001
Location: Winchester ,Virginia , United States
Age: 64
Posts: 2,081
I have found, if you upgrade after install manualy to 1.29 then load SoU it will put in the correct 1.30 upgrade, and you won't have the Invalid pointer Operation statement. I did it that way and have never had any of the problems that have been stated in the past couple of weeks on all the forums.
__________________
Remember these are just games so don't get too upset
when you get your ass handed to you in a hat box
TheCrimsomBlade is offline   Reply With Quote
Old 07-01-2003, 12:21 AM   #5
SpiritWarrior
Jack Burton
 

Join Date: May 31, 2002
Location: Ireland
Posts: 5,854
Yep, The CrimsomBlade is dead right on that fix. The only thing is I don't know if you are actually using SOU (the expansion to this game). What version are you running..NWN's...SOU?
Regardless, a few suggestions in no particularer order:

1)Check for hakpacks you have installed - sometimes these interfere with patching, and make a copy of your hak folder then delete the other (even on a re-installation these can remain so don't rule it out).

2)Try the manual patch itself, you can get it on the Bioware site.

3)If all else fails, post your error message on the Technical Forums at Bioware.

P.S. You really should update to 1.30 though, so don't give up as they have fixed/added a huge amount of stuff which really helps.
__________________
Still I feel like a child when I look at the moon, maybe I grew up a little too soon...
SpiritWarrior is offline   Reply With Quote
Old 07-01-2003, 12:24 PM   #6
SpiritWarrior
Jack Burton
 

Join Date: May 31, 2002
Location: Ireland
Posts: 5,854
Hey mate I found out for you. This bug is well known and...they have a fix for it too . Go here and scroll down to the 'Invalid Pointer fix' part. [img]smile.gif[/img]
http://nwn.bioware.com/support/patch_beta.html#misc
__________________
Still I feel like a child when I look at the moon, maybe I grew up a little too soon...
SpiritWarrior is offline   Reply With Quote
Old 07-01-2003, 05:11 PM   #7
Tyranny]SiN[
The Magister
 

Join Date: August 29, 2002
Location: Faerun
Age: 36
Posts: 102
I don't have SOU yet. Just NWN - Thanx Crimson - I'll let u known if it works.


these instructions are confusing and they contradict themselves

Misc Beta Patch
Current Misc Beta Patch: 1.30 "Invalid Pointer Operation" Beta Fix
Updated: Thursday, June 26, 2003, 5:30pm MT

With version 1.30 of Neverwinter Nights or Shadows of Undrentide, you may see an Invalid Pointer Operation error message when trying to start the game from the launcher. This Beta nwn.exe program should fix this issue.

You MUST back up your old nwn.exe file before you install the new one. You will be required to restore from your backup before you will be able to use the final 1.31 Update.

This doesn't make any sense to me - I Back up my old nwn.exe, I do as the instructions ask and unzip the Beta nwn.exe on the not backup nwn.exe and then I install the 1.31 patch? What do I do wif the backed up copy of my old nwn.exe? It also adds that I'm patched without patching with the 1.31 update, do I even install the 1.31 update?


------------------------------------------------------------------
Ok I did as the instructions said - but was iffy on the last part - I did the update and this is what I got - More trouble!


An incorrect version of the file was found on your system.
The update was unable to complete, since the file contents were incorrect.
C:\NWN\nwn.exe
File Size: 5767680
File CheckSum: 3787c7b0df41bfb45f94b8d82ec1ed03
Get the critical rebuild.
http://nwn.bioware.com/support/patch_english.html#crit
The patch has been aborted


================================================== ===================
Ok this is what I did on my own Recognicense -

I took the back up I made and put it over the beta patch -
I D/l'd the Critical rebuild patch from the website the patch error gave me.

and.... i get the same error as i did the first time - I'm just not going to update.

Bioware should really iron out his bug for us persons that have this problem.

================================================== ===================
Ok, this is driving me crazy now, I'm determined to patch this F*****!! and have it work!!!

Ok doing a clean install wif the Critical Rebuild 1.30 patch. I'm rebooting.

[ 07-01-2003, 06:05 PM: Message edited by: Tyranny]SiN[ ]
Tyranny]SiN[ is offline   Reply With Quote
Old 07-01-2003, 06:21 PM   #8
Tyranny]SiN[
The Magister
 

Join Date: August 29, 2002
Location: Faerun
Age: 36
Posts: 102
I figured it out!

Its much easier doing it this way then the way that bioware simply confuses the ~censored~ out of you.

1. Download the Critical Rebuild File Update 1.30 patch from this website:
http://nwn.bioware.com/support/patch_english.html#crit

2. Download the NWNBeta.exe from this website:
http://nwn.bioware.com/support/patchdetails.html

3. After you execute the CRFU (critical rebuild file update) after it installs put the NWNbeta.exe in the NWN install directory.

then the Invalid pointer operation disappears.
=================================================

Why didn't bioware just say that?? Its like Bioware didn't even test it b4 they put it on their site!!

[ 07-01-2003, 07:37 PM: Message edited by: Larry_OHF ]
Tyranny]SiN[ is offline   Reply With Quote
Old 07-02-2003, 01:57 AM   #9
SpiritWarrior
Jack Burton
 

Join Date: May 31, 2002
Location: Ireland
Posts: 5,854
Good news .
__________________
Still I feel like a child when I look at the moon, maybe I grew up a little too soon...
SpiritWarrior is offline   Reply With Quote
Old 07-05-2003, 06:04 PM   #10
SpiritWarrior
Jack Burton
 

Join Date: May 31, 2002
Location: Ireland
Posts: 5,854
Could someone who is using 1.30 with regular NWN's only check for me if 20th level monks have glowing eyes. Thanks!
__________________
Still I feel like a child when I look at the moon, maybe I grew up a little too soon...
SpiritWarrior is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Report bugs or errors/mistakes in EfU here (11/3/2008 Onwards) T-D-C NWN Mod: Escape from Undermountain 57 11-02-2008 10:19 PM
Report bugs or errors/mistakes in EfU here Ziroc NWN Mod: Escape from Undermountain 408 11-14-2006 04:15 AM
BETA 1.30 patch out>>>Report Trouble or ask Patch Questions Here philip Neverwinter Nights 1 & 2 Also SoU & HotU Forum 24 06-19-2003 05:42 PM
NWN Patch 1.29>>>Report trouble or ask patch questions here Larry_OHF Neverwinter Nights 1 & 2 Also SoU & HotU Forum 36 06-14-2003 10:57 AM
ATTN: Please report bugs, problems and workarounds HERE Memnoch Neverwinter Nights 1 & 2 Also SoU & HotU Forum 61 07-18-2002 11:42 AM


All times are GMT -4. The time now is 09:40 AM.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
©2017 Ironworks Gaming TM & The Great Escape Studios - All Rights Reserved