Ironworks Gaming Forum

Ironworks Gaming Forum (http://www.ironworksforum.com/forum/index.php)
-   Baldurs Gate II: Shadows of Amn & Throne of Bhaal (http://www.ironworksforum.com/forum/forumdisplay.php?f=12)
-   -   Lavok the Silent (spoiler) (http://www.ironworksforum.com/forum/showthread.php?t=16895)

kev 02-14-2006 08:57 AM

Why wont Lavok talk to me?

I have completed the sphere completly and am back in the real world. My main charactor is a mage so I have to talk to Lavok to get the stronghold.

After I completed all the things I needed to do in the Sphere I blasted Lavok with several fireballs from outside his line of vision.
I ended up with the 'subdued' version of Lavok but never had any dialogue with him. He was 'near death'.
I tried healing him & now he is not injured, but he still won't talk to me. I even tried to kill him outright but he wont die, just gets to 'near death'.

I am a long way past this now & don't have any save games to go back to.

I don't think I need a patch because I have 'Throne of Bhaal' installed.

Can anyone give me any ideas?

Kev

Link 02-14-2006 09:04 AM

The fact that you have Throne of Bhaal changes nothing to that! Always patch your game!!

Check out the FAQ to find out where to get everything, including the Fixpack by Baldurdash.

[ 02-14-2006, 08:05 AM: Message edited by: Link ]

kev 02-14-2006 09:08 AM

I will give that a shot.
I didn't patch the game because the TOB readme said that it had the patch included.

cheers
Kev.

Armen 02-14-2006 09:42 AM

it'll have the SoA patch but there's a ToB patch too

Illumina Drathiran'ar 02-15-2006 03:25 AM

Why don't you have an autosave? Did you have an initial dialogue with Lavok? If not, the game is probably very, very confused... I think Ao is smiting you for using cheese. It's not a bug because you tried to cheat the system, right? I would try to CLUA in the original Lavok and hope for the best... And this time, let him TALK to you before you let loose, kay?

kev 02-15-2006 08:39 AM

I tried the patches but it was probably too late in my case. I have spent several hours since Lavok so I have no saves at that part of the game.
I guess next time I need to initate dialaogue before I kill him.
Now I have other things to think about. I have an assertion problem so cant play my game at all. But that's another thread.


All times are GMT -4. The time now is 07:50 AM.

Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
2022 Ironworks Gaming & 2022 The Great Escape Studios TM - All Rights Reserved